Keyboard Missing. Hit F1 to continue …

Laptop crashed as a Friday night surprise.

Every reboot option ended up at a C:\> prompt and I had no clue what command could be run. Tried all unix commands hoping some might work on Windows by coincidence (yeah, DATE works).

Finally recalled something called DIR, but it showed there are no DIR’s in my hdd. 🙁

Tried to shutdown.. tried …
exit: bad command
shutdown: bad command
bye: bad command
disconnect: bad command
quit:
(Didn’t wait to try this one. Just pressed power button.)

So, the OS (hopefully not the whole hdd) was gone. All I needed was Windows7 installer dvd or USB drive. Oh, now I understand why my new USB drive has gone missing since yesterday!

Finally, the guy-next-door was in. Used his pc to make a Win7 installer flash drive.
All cool, now just gonna re-install the OS.

Win7 installer asked: “upgrade or new install? ‘Upgrade’ will keep your files, ‘New install’ will not.”
I was not sure but remembered I had lots of documents on the desktop.. so let’s not do a new install. Let’s upgrade. But it said, “if you wanna upgrade, start your existing OS, run the installer from therein and chose ‘upgrade’..”
What the.. Why shud I upgrade (instead of watching movie) if my OS were working?

I was thinking whether to let it go and do a new install…; after 1 hr, decided to let the docs go.

Chose “new install”. Now it says: “Your hdd is RAW, not formatted. Format now?” (You mean there is nothing on the hdd and want to format the 250GB data!!!)

I said, “come again? there is nothing on the hdd?” It said “yes,no.”
I took a step back and chose “repair”. It said “Can’t repair. Nothing is there to repair. Can’t detect any Windows installation.”
I chose “restore”. It said “no backups available.”

Now am damn desperate to know if something still exists on my hdd. Only solution was a live cd. Linux seemed too user-enemily. So bartPE is the option. Again made a PE CD on neighbour’s pc and booted.. Looked for hdd.. it did not exist at all!! 🙁 🙁

What do I do? Need to research what can be done. And need a computer for research.

Then remembered the recently bought (for charity) warranty-expired, old, damn-old, desktop. Huh, it came with the user-enemily linux. Let’s install Win xp on it and make it usable. At guy-next-door’s again.

Connected cables and switched it on. It said “keyboard missing, please press F1 or F2 to continue.” Now that’s beyond human capabilities…

However, I connected a keyboard.. started installation.. Now realized the drivers CD was not provided with the desktop.

Can download from internet though. Wait, don’t we need ethernet driver first, for internet to work? 🙁

Oh! I had forgotten the wireless data card lying on the desk. That can be used to download the ethernet driver. Installed the data card drivers. Let’s start the internet! And it needs a login!! I don’t remember it. Can’t disturb ppl at 2am to ask the login.. Last thing I remember about the login was it being a phone number. E-mails and Internet, unfortunately, don’t (have the guts to) support regex search.

My phone refused to connect GPRS… went outdoors and it now connected. Searched random emails from the friend and found a couple of phone numbers in different context.. ran back and one of those worked!


2 Responses to “Keyboard Missing. Hit F1 to continue …”

Say something...